ESpec - мир электроники для профессионалов


Samsung ML-1645 погас после левой прошивки

  Список форумов » Периферийные устройства
На страницу 1, 2  След.
Следующая тема · Предыдущая тема
АвторСообщение
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #1 от 31/10/2014 19:45 цитата  

ребят..такое дело..прошил принтер неудачно прошивкой не для этого принтера..всё погасло..

сообразил дебаг-кабель,эхо норм...откликнулся принтер на скорости 38400 б/сек и он ответил так:

[HWIC]

1PLL

2IOC

3SDRAM

4GPIO

5AHB

[END] [Y]

Decompression***********

-->>>>GO Kernel

jump_ExecCode():ul_addr - 0x02008000

[0x207CCD8]

вот...подскажите..что бы это значило?
Олег Ал 
Модератор
<B>Модератор</B>
Сообщения: 984
 
Сообщение #2 от 01/11/2014 09:03 цитата  

а в принудиловке не пробовали оригинал залить сначала
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #3 от 02/11/2014 18:28 цитата  

он даже не реагирует на включение теперь...а принудиловка - при условии что он хотя бы светится огоньками?или какой-то другой метод?
Олег Ал 
Модератор
<B>Модератор</B>
Сообщения: 984
 
Сообщение #4 от 02/11/2014 18:48 цитата  

http://overchip.ru/forced_mode/ попробуйте, может получится
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #5 от 02/11/2014 20:09 цитата  

это уже опробовано...но без результатно...он же даже не светится.. просто после включения......попробую прошить чистую память и впаять в принтер
говорят в принтерах дебаг не работает на передачу.,а только на приём
так что похоже это единственный метод на данный момент ,который может помочь в данной ситуации,но не факт
Кр. Вован 
Завсегдатай
Сообщения: 978
Кр. Вован
 
Сообщение #6 от 02/11/2014 21:22 цитата  

саня-22, дэбаг-кабель должен без проблем работать на скорости 115200, 8 бит, чётность - "нет", стопки - "1" и управление потоком - "нет"...все манипуляции с дэбагом давно расписаны в и-нете и никаких проблем с поиском нет...И напиши что залили и что было изначально (версия какая была)?...Да и без шнурка в принудилово можно попробовать загнать "Удерживая кнопку "Печать экрана", которая расположена выше кнопки включения на принтере - включите принтер"...

ДОБАВЛЕНО 02/11/2014 21:27

саня-22 писал:

говорят в принтерах дебаг не работает на передачу.,а только на приём

Возможно на разъёме de-bug на майне принтера отсутствует перемычка (что не удивительно для самсуня - типа защита такая)...

ДОБАВЛЕНО 02/11/2014 21:33

саня-22 писал:

сообразил дебаг-кабель,эхо норм...откликнулся принтер на скорости 38400 б/сек и он ответил так:

[HWIC]

1PLL

2IOC

3SDRAM

4GPIO

5AHB

[END] [Y]

Decompression***********

-->>>>GO Kernel

jump_ExecCode():ul_addr - 0x02008000

[0x207CCD8]

вот...подскажите..что бы это значило?

Кстати, перед включением принтера кнопочку "N" на клаве компа не забыл держать?
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #7 от 02/11/2014 22:09 цитата  

на скорости 115200 рисовал кракозябру....,
пробовал и с N нажатой...только печаталось по несколько буковок nnnnnnnnnn и отличия никакого небыло,
прошивку не помню какую загнал,прошло много времени с тех пор,пылью успел покрыться)
пробовал и удерживая кнопку Печать экрана загнать прошивку,но аппарат для компьютера вообще невидим,т.к. ни одна сигнализирующая о работе принтера лампочка не рабо
Кр. Вован 
Завсегдатай
Сообщения: 978
Кр. Вован
 
Сообщение #8 от 02/11/2014 22:14 цитата  

По прошивке через де-баг тут подробно всё описано (может ругаться антивирь)
http://www.reset-printers.com/debug.html
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #9 от 03/11/2014 09:39 цитата  

по ссылке откидывает на главную Еспеца,так же и при вводе в главную строку
Владимир Ар. 
Передовик
Сообщения: 1078
 
Сообщение #10 от 03/11/2014 09:46 цитата  

На ссылку ненадо жать, так ибудет откидывать на главную Надо скопировать ссылку и вставить в строку, все будет работать(проверил тока что).
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #11 от 03/11/2014 20:35 цитата  

а перемычку не подскажете где на ML-1645 найти,искал в инете ,но так ничего и не нашел
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #12 от 03/11/2014 21:12 цитата  

Кр. Вован писал:
По прошивке через де-баг тут подробно всё описано (может ругаться антивирь)
http://www.reset-printers.com/debug.html

это всё уже пройденный этап,нужного отклика с нажатой буковкой N не получается ,эта статья про МФУ,а принтер по проще будет...с ним такой фокус не прошол...,и дебаг собран правильно (проверено эхом)
Кр. Вован 
Завсегдатай
Сообщения: 978
Кр. Вован
 
Сообщение #13 от 03/11/2014 22:43 цитата  

саня-22, с простыми принтерами (не МФУ) это точно так же работает...проверено...
саня-22 писал:
а перемычку не подскажете где на ML-1645 найти,искал в инете ,но так ничего и не нашел

Посмотри в районе разъёма де-баг на майне отсутствие деталюшек...а лучше дай качественное фото с двух сторон...
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #14 от 04/11/2014 08:45 цитата  

саня-22 писал:
Кр. Вован писал:
По прошивке через де-баг тут подробно всё описано (может ругаться антивирь)
http://www.reset-printers.com/debug.html

это всё уже пройденный этап,нужного отклика с нажатой буковкой N не получается ,эта статья про МФУ,а принтер по проще будет...с ним такой фокус не прошол...,и дебаг собран правильно (проверено эхом)

у меня со 2 ножки МС конденсатор припаян к +пит-только так принтер хоть что-то пишет,а припаиваю к - пит-молчит(не просто молчит ,а пишет ,что -не удаётся открыть СОМ 1),где-то прочитал что это неправильная схема с ошибкой,хотя у кого-то и работает

ДОБАВЛЕНО 04/11/2014 09:48

Кр. Вован писал:
саня-22, с простыми принтерами (не МФУ) это точно так же работает...проверено...
саня-22 писал:
а перемычку не подскажете где на ML-1645 найти,искал в инете ,но так ничего и не нашел

Посмотри в районе разъёма де-баг на майне отсутствие деталюшек...а лучше дай качественное фото с двух сторон...

фотика под рукой нет,нашел обрыв от Rx ,поставил перемычку,постарюсь найти фотик-выложу фотки,а пока поэкперементирую
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #15 от 04/11/2014 12:12 цитата  

Тх-выходит на 41 ножку проца,Rх-на 42 ножку ,всё норм звонится...дальше уже смекалки не хватает..ищу по форумам
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #16 от 04/11/2014 17:06 цитата  

3SDRAM
4GPIO
5AHB
[END]
jump_ExecCode() : ul_addr - 0x02600000
======================
Start flash_writer
======================
[Iflash]=== Iflash_HWProtection ===
verify_Image : 0x02700000
i_header->pul_start_addr : 0x00000000
i_header->ul_count : 0x00000000
temp_buf :
SIG : $IMG
Download Image from PC

ДОБАВЛЕНО 04/11/2014 18:07

{
Download destination Address : 0x02700000
Please send data via usb (ISP1582)!!!
CSB Chip Device ID= 0000F1AD0000F00Eey
A][Y]
Decompression ***********
-->>>> GO Kernel
jump_ExecCode() : ul_addr - 0x02008000
InitializeWDT
[0x207CCD8]

ДОБАВЛЕНО 04/11/2014 18:08

а вот так при нажатой кнопке Стоп при включении принтера,извиняйте фото не умею вставлять

ДОБАВЛЕНО 04/11/2014 18:12

похоже единственный выход-JTAG ?

ДОБАВЛЕНО 04/11/2014 18:18

он похоже уже подключает порт с юс би, но тут же выдаёт какую-то ошибку- не дорисовывает до конца продолжение текста
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #17 от 05/11/2014 20:42 цитата  

что это значит,никто не может пояснить?
Кр. Вован 
Завсегдатай
Сообщения: 978
Кр. Вован
 
Сообщение #18 от 05/11/2014 22:34 цитата  

И всё таки что то не так с де-багом...В самом начале должна отображаться инфа о проце, а потом о флеш...
саня-22 
Бывалый
Сообщения: 53
саня-22
 
Сообщение #19 от 05/11/2014 23:42 цитата  

у меня на МАХ 232 со 2 ножки конденсатор припаян к ,+, пит,припаиваю к ,-, и микросхема начинает греться и терминал перестаёт вообще считывать информацию с проца.....перепроверю конечно ,но может дело в СОМ порте?писали где-то что у него тоже меняют поляризацию импульсов.Для начала запускают программу тестирования портов,а потом где-то в БИОСе исправляют изъян...И только после этого можно припаять конденсатор к ,-, пит ,так что бы дебаг начал работать полноценно..
Кр. Вован 
Завсегдатай
Сообщения: 978
Кр. Вован
 
Сообщение #20 от 06/11/2014 10:47 цитата  

Собирал по этой схеме http://www.testcopy.ru/practikum/34/135.html всё завелось без проблем...Да и с настройкой COM-порта проблем небыло на WIN7...правда на ХР пришлось потанцевать с бубном...

Перейти: 
Следующая тема · Предыдущая тема
На страницу 1, 2  След.
Показать/скрыть Ваши права в разделе

Интересное от ESpec


Другие темы раздела Периферийные устройства



liveinternet.ru RadioTOP Rambler's Top100 Рейтинг@Mail.ru