ESpec - мир электроники для профессионалов


Nikon D40 не включается.

  Список форумов » Фотоаппараты
На страницу 1, 2  След.
Следующая тема · Предыдущая тема
АвторСообщение
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #1 от 17/10/2012 23:17 цитата  

Здравствуйте,
Приобрел тут по дешевке не рабочий Nikon D40. Не включается. По словам прошлого владельца в аппарат заползло парочку муравьев, и, действительно, разобрав фотоаппарат, обнаружил там несколько высохших трупиков.
Перед разборкой хотел измерить ток потребления - оказался НОЛЬ. Добравшись до DC/DC PCB нашел там один убитый предохранитель (на картинке FUSE1).
Вопрос 1: что это за предохранитель (всмысле как его найти в магазине)?
Вопрос 2: имеются ли еще другие предохранители, а то поиск по repair manual ничего не дает?
Вопрос 3: что могло вызвать смерть предохранителя, если какой-либо элемент, то на кого обратить внимание в первую очередь?
Вопрос 4: резервная батарея была разряжена в ноль - это симптом?

  DC-DC.JPG  68.19 КБ  Скачано: 956 раз(а)
NikolaiMalaxov 
Передовик
Сообщения: 1044
NikolaiMalaxov
 
Сообщение #2 от 17/10/2012 23:25 цитата  

inmaze, замени предохранитель(smd резистор нулевой)включи.батарею поставь на зарядку.
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #3 от 18/10/2012 22:34 цитата  

Спасибо за ответ. Пока проблема осталась.

1. Предохранитель заменил медной проволочкой, так как в магазине не оказалось ни fuse-ов , ни резисторов в smd корпусе такого маленького размера.
2. Батарейку (не аккумулятор, а именно резервную батарейку CR 1220) заменил.
Собрал. Аппарат не завелся.

Попробовал померить потребляемый ток. Картина такая. Выставляю на блоке питания 7.5В, подключаю к аппарату и вижу следуещее: даже при выключенной кнопке ON/OFF на фотоаппарате, ток течет импульсно - нет, нет, нет, потом скачек до максимума, который может выдать блок - 2.5А, причем такой быстрый, что на амперметре даже не вдино, а видно по проседанию напряжения на блоке питания, потом снова секунду - две ноль.

В каком направлении копать?
NikolaiMalaxov 
Передовик
Сообщения: 1044
NikolaiMalaxov
 
Сообщение #4 от 18/10/2012 23:13 цитата  

inmaze, копать-в огороде!запитай от БП с ограничением по току в 1-2 ампера,посмотри не греется ли что,скорее проблема у тебя с питанием.проверь стабы.
HaOS 
Участник
Сообщения: 154
HaOS
 
Сообщение #5 от 22/10/2012 13:49 цитата  

Это так, на всякий случай... И картинки с фузами

http://www.ebay.co.uk/itm/270740668263?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1423.l2649
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #6 от 24/10/2012 21:34 цитата  

Спасибо за ответы и ссылку на предохранители, но я думаю, что пока можно обойтись и проволочкой.

Текущее состояние:
Плата DC/DC PCB unit (на которой предохранитель) абсолютно живая - поставил ее на другой фотоаппарат - все работает.
Методом исключения выявил, что проблема где-то на плате которая в мануале идет как TOGO PCB unit (самая большая - см. прикрепленный рисунок). Если к подсоединить шлейф Harness (кучка белых проводков от DC/DC платы) и подать питание 7.5 с ограничением по току в 2А. (можно через плату DC/DC или напрямую (два крайних провода в шлейфе Harness)), то происходит вот что:
И с интервалом примерно раз в секунду (с осцилографом не смотрел) происходит скачек тока с нуля до максимума и, соответсвенно, проседание напряжения.
Кого винить, и как дальше искать неисправный элемент? Греться то он наверное не будет - огромный ток течет не постоянно, а импульсно.

TOGO PCB.jpg
 Описание:
 Размер файла:  243.3 КБ
 Просмотрено:  751 раз(а)

TOGO PCB.jpg


inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #7 от 26/10/2012 20:40 цитата  

Так, я был в корне не прав: проблема не в той плате, в которой я думал и написал в предыдущем посте. А там был просто глюк, связанный с тем, что я поставил ограничение тока почти на 0, и фотоапарат пытался завестись, но тока не хватало.
Но симптомы настоящей проблемы все те же - ток возрастает до максимума, просаживая напряжение.
Но виновата оказалась другая плата, а именно - RELAY PCB unit. Проблема проявлялась только когда к ней было припаяно и питание (2 проводка через плату вспышки) и подключен шлейф.
Иногда мне везло, и напряжение не проваливалось так сильно - и гоняя максимальный ток, я увидел, что греется микросхема с маркировкой S139 (см на рисунке). Выяснил, что это полевой транзистор (поправте если я не прав) с маркировкой FSS139 (в инете полно описаний) производсва SANYO. При этом он не был пробит - если не подключать шлейф, то он не открывается и ток не течет, да и сопротивление исток- сток тоже мегаомы. Пошукав рядом, я увидел, что сдох диод (см на картинке).
С маркировкой диода я не понял - поискал в инете цветовую маркировку - система вроде американская, но что обозначают полученные цифорки из цветов (коричневый - зеленый - зеленый) = (155) я так и не понял.
Если расскажет кто-нить буду рад.
Таким образом, в ближайшее время зайду в магазин и попрошу такой же диодик, поменяю и посмотрю, что получиться.
Но чтоб добраться до этой платы, пришлось снимать матрицу. Как написано в инструкции, после этого требуется калбировка при помощи программного обеспечения. Что с этим делать? Раскройте пожалуйста тему, кто знает.

Итак, если кто может направьте по след. пунктам:
1. значение маркировки диодов.
2. что делать с юстировкой матрицы?




reley unit.jpg
 Описание:
 Размер файла:  432.29 КБ
 Просмотрено:  346 раз(а)

reley unit.jpg


Иван Зенин 
Модератор
<B>Модератор</B>
Сообщения: 6561
Иван Зенин
 
Сообщение #8 от 26/10/2012 21:14 цитата  

inmaze, если матрица прикручена без пружинок,то настройка не потребуется.
Samand 
Участник
Сообщения: 288
Samand
 
Сообщение #9 от 27/10/2012 09:29 цитата  

inmaze, Это не диодик, а стабилитрон RLZ7.5B на 7,5 в.

  THE SMD CODE BOOK_2100.jpg  97.91 КБ  Скачано: 520 раз(а)
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #10 от 28/10/2012 00:45 цитата  

Спасибо всем за участие.
Иван Зенин писал:
inmaze, если матрица прикручена без пружинок,то настройка не потребуется.

Нет пружинок никаких нет, но матрица может гулять 1-2 мм в плоскости кадра.

Samand писал:
inmaze, Это не диодик, а стабилитрон RLZ7.5B на 7,5 в.

Да...протормозил я с "диодом", уже когда впаивать собрался - смутило меня: "а нафига это диод с "+" на "-" напрямую кидать?". И как раз в форум заглянул... Но ничего успел в магазин сбегать и стабилитрон купить.
Все собрал, фотоаппарат включился, я радостный выставил дату и время, сфокусировался в автоматическом режиме и нажал спусковую кнопку.

И тут это случилось.
На карте появился абсолютно черный кадр, а на экране выскочила ошибка: "Нажмите спусковую кнопку затвора еще раз."
В механику при разборке я даже и не лез. Зеркало свободно ходит (если пальчиком потрогать).
Нашел, что что надо смазкой брызнуть в главную шестерню
http://www.digitalphotographer.com.ph/forum/showthread.php?33325-Nikon-D60-40-40x-quot-Error-Press-Shutter-Release-Button-Again-quot-(SOLUTION)
Попробую брызнуть.
Видел ветку http://monitor.espec.ws/section45/topic197223.html
Попробую дальше поковыряться.
Зря я конечно файлик удалил сразу - можно было бы посмотреть, сколько выстрелов отработал затвор.
Советы? Предложения?
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #11 от 28/10/2012 23:49 цитата  

Разобрал, брызгать ничем не стал:
подвигал отверткой шестерню - зеркало поднимается и опускается. Если подать напряжение на двигатель - то он крутит зеркалом вверх (+5В) и вниз (-5В). Сопротивление двигателя 4.5 Ом.
Я, правда, наверное убил драйвер, так как не отпаивал движок, когда подавал напряжение. я такой вывод сделал почитав ветку на одном из форумов с весьма одноименным названием:
http://www.mobile-files.ru/forum/showthread.php?t=237947&highlight=nikon
Кроме всего прочего кондер не заряжается, а вот поднимается вспышка или нет - не проверил.
Повторюсь - ошибка выскочила только когда я первый раз нажал кнопку спуска затвора.
Кто мог сдохнуть?
Иван Зенин 
Модератор
<B>Модератор</B>
Сообщения: 6561
Иван Зенин
 
Сообщение #12 от 29/10/2012 07:30 цитата  

inmaze, попробуй сделать снимок с отстёгнутым объективом.
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #13 от 29/10/2012 23:15 цитата  

Он не дает сделать снимок - сразу после включения (с или без объектива) выдает ошибку.
Иван Зенин 
Модератор
<B>Модератор</B>
Сообщения: 6561
Иван Зенин
 
Сообщение #14 от 29/10/2012 23:21 цитата  

inmaze, шестерню программную не смотрел ещё?
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #15 от 30/10/2012 01:15 цитата  

программная шестерня - эта та, которая на оси двигателя? Красненькая такая, которая на фото?

  shesternya.JPG  41.98 КБ  Скачано: 358 раз(а)
Иван Зенин 
Модератор
<B>Модератор</B>
Сообщения: 6561
Иван Зенин
 
Сообщение #16 от 30/10/2012 06:55 цитата  

Нет,это шестерня с контактами на пластиковых заклёпках,которые имеют свойство отламываться.Пример D80.




inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #17 от 31/10/2012 02:10 цитата  

Программная шестерня цела - если прокручивать пальчиком красную шестеренку на двигателе зеркала, то видно, что обе заклепки в порядке.
Но, методом тыка и перекидывания с мертвого на живого (фотоаппарат жены (тоже кстати покупал не рабочим, но дефект был простым)) выяснил, что не работает плата управления двигателем затвора (на которой был дохлый стабилитрон - фото выше reley unit.jpg). Прозвонив контакты драйвера L8011, обнаружил, что цифровые контакты (которые идут в драйвер от CPU) пробиты на землю (IN1, IN2, EN по 5кОм, а TIN - вообще 44 Ома вместо положенных 6-8 МОм (как на живой плате)).
Таким образом - драйвер двигателя сдох. Нашел в инете где можно купить, но когда получиться заказать - даже не знаю - постараюсь к институтскому заказу прицепить.
CPU как я понимаю не мог поддохнуть, так как на другой, гарантированно рабочей плате находиться.

Но, выяснилось что есть еще одна проблема. Собрав дохляка с reley unit от живого фотоаппарата - он заработал - делает фото, фокусируется, НО ВСПЫШКА НЕ РАБОТАЕТ. Он ее поднимает, ошибок на экране не выдает, но не пыхает. Сегодня уже не успел посмотреть заряжает ли кондер. Будет время поковыряюсь.
Да... какой то кармический фэйл, а не фотоаппарат: Выгоревший предохранитель - выгоревший стабилитрон - сдохший драйвер, а теперь еще и вспышка.
inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #18 от 31/10/2012 23:43 цитата  

Итак, перекидыванием с мертвого на живого выяснил что за отсутствие вспышки виновата плата, к которой припаян конденсатор вспышки (см рис.). Поколдовав над ней нашел, что пробит диод (см. рис.)

Вопрос 1. Как понять, что это за диод?

Что за корпус? длина 1,2+- 0.2мм, ширина 0.5+-0.1мм. википедия говорит, что в смд диоды бывают только SOD-323 и SOD-123, но они больше по размеру.
http://ru.wikipedia.org/wiki/SMD
Падение напряжения, если мерить мультиметром в режиме диодов, 1,96 В.

И вообще, пока разбирался с трупом - угробил рабочий фотоаппарат: перестала работать вспышка, причем, если на дохляке она поднималсь, фотоаппарат делал снимок, просто вспышка не срабатывала, то на этом она поднимается, но при нажатии кнопки спуска затвора он не делает ничего. (без вспышки все работает).
При разрядке кондера я неудачно замкнул ножки резистора, и он разрядился напрямую через проволочку с неплохим таким хлопком. после сборки и обнаружения не работоспособности - еще не проверил, заряжает ли он кондер.
Вопрос 2. Может такая разрядка быть причиной? Какие другие варианты?

flash.jpg
 Описание:
 Размер файла:  397.61 КБ
 Просмотрено:  304 раз(а)

flash.jpg


inmaze 
Новичок
Сообщения: 18
inmaze
 
Сообщение #19 от 03/11/2012 01:15 цитата  

Ребята, нет ни каких соображений?
Что-то я не могу найти диода в корпусе 0402. Самое маленькое, что нашел - это в 0603 ( ссылка в конце сообщения).
Или я может что путаю? стоит это элемент вроде на пути от IGBT транзистора 25J8F (который с 8-ю ногами) с ножки, которая вроде как gate к микроконтроллеру на той же плате, но с другой стороны.

И что я мог сделать со вторым фотом? повторю симптомы - вспышка поднимается, но при нажатии кнопки спуска затвора - ничего не происходит (он, наверное, ожидает сигнала о том, что вспышка заряжена)

ссылка на диод:
http://uk.farnell.com/taiwan-semiconductor/ts4148-rzg/diode-0-35a-603/dp/8150192
ссылка на даташит аналога 25j8F:
http://www.ic-on-line.cn/view_download.php?id=1365913&file=0176\cy25baj-8f-t13_4258268.pdf

diod.jpg
 Описание:
 Размер файла:  707.85 КБ
 Просмотрено:  194 раз(а)

diod.jpg


Иван Зенин 
Модератор
<B>Модератор</B>
Сообщения: 6561
Иван Зенин
 
Сообщение #20 от 03/11/2012 07:58 цитата  

inmaze писал:
И что я мог сделать со вторым фотом?

inmaze писал:
я неудачно замкнул ножки резистора, и он разрядился напрямую через проволочку с неплохим таким хлопком

Последствия сего деяния в 95% случаев весьма плачевны для аппаратов (попросту имеем полный труп).Мощный разряд может выбить непредсказуемо что угодно.

Перейти: 
Следующая тема · Предыдущая тема
На страницу 1, 2  След.
Показать/скрыть Ваши права в разделе

Интересное от ESpec


Другие темы раздела Фотоаппараты



liveinternet.ru RadioTOP Rambler's Top100 Рейтинг@Mail.ru