ESpec - мир электроники для профессионалов


MSI KA780G MS-7551 не работает PS/2

  Список форумов » Настольные компьютеры

Следующая тема · Предыдущая тема
АвторСообщение
alex_kvb 
Бывалый
Сообщения: 38
 
Сообщение #1 от 21/12/2015 00:36 цитата  

MSI KA780G MS-7551 ver:1.0

Такая проблема. Не работает клавиатура PS/2. USB клавиатура работает только под ОС, в биосе требует нажать F1 или F2, но нажать ничего не получается. При старте иногда останавливается на коде С7.
Проверил обвязку порта, ничего не нашел подозрительного. 5В есть. Измеренная емкость сигнальных линий гнезда PS/2 (330 пф) примерно равна емкости других плат.
Cхемы на 7551 не нашел, реализацию PS/2 зарисовал с натуры. Сравнение c рабочей платой MS-7550 выявило, что отличаюся напряжения на выводах 70 KBCLK и 72 MSCLK мульта F71882. Должно быть 5,0,5 (дежурный, ресет, старт), а есть 5,0,0. И отличаются в дежурном режиме напряжение на выводах 40 KBRST# и 41 A20GATE - на рабочей 7550 - 0,27v, на 7550 - 1,2v. В рабочем режиме по 3,36v.
В мониторинге загруженной ОС отображается только температуры процессора и HDD. Вроде бы все указывает на мульт, но смущает, что не работает USB клавиатура при старте. Заливал биос от 7550 (где все работает) - поведение не меняется. Ставил мульт с платы с разборки - ничего не поменялось. Неужели это Юг, но ведь USB порты работают. Искал темы с подобной проблемой, но решения так и не нашел, подскажите куда смотреть?

Напряжения:

CPU - 1,29v
СМ - 1,1v, 1,83v, 3,35v
ЮМ - 1,21v, 3,36v
ПАМЯТЬ - 1,91v
CMOS - 2,99v
POVER-ON - 3,24v
RESET - 3,35v




  7551_keyboard.pdf  66.25 КБ  Скачано: 204 раз(а)
n max 
Модератор
<B>Модератор</B>
Сообщения: 11680
 
Сообщение #2 от 21/12/2015 01:38 цитата  

С разъёма пс\2 прозвонить сигнальные линии до мульта до самих ног-мож плату ломанули или сам разъём,юг прямой связи с пс\2 не имеет и на работу влиять не должен.
В биосе усб клавиатура не работает на многих платах,видать эту процедуру не добавили за невеликой надобностью
blek1 
Передовик
Сообщения: 1212
blek1
 
Сообщение #3 от 21/12/2015 08:03 цитата  

А то,что у вас одно ядро ЦП 4"С градуса-это норм?
alex_kvb 
Бывалый
Сообщения: 38
 
Сообщение #4 от 21/12/2015 16:16 цитата  

n max писал:
С разъёма пс\2 прозвонить сигнальные линии до мульта до самих ног-мож плату ломанули или сам разъём,юг прямой связи с пс\2 не имеет и на работу влиять не должен.

Для проверки целостности линий прямым способом я с рабочей платы кинул 3 провода KDATA (69) KCLK (70) и корпус на такие же выводы мульта другой платы. Включил 7551 в дежурный режим, что бы дополнительно проверить 5В на PS/2 и подключил клавиатуру. Получилась 7550 с интерфейсом от 7551. Клавиатура работает, значит после мульта все целое. Если запустить 7550, то 70 вывод садится на корпус, клавиатура перестает работат, в дежурном режиме, когда на 70 выводе 5В - работает.

Цитата:

В биосе усб клавиатура не работает на многих платах,видать эту процедуру не добавили за невеликой надобностью

Я залил биос от 7551 в 7550. Действительно в биос по нажатию DEL не заходит, но заходит в следующем окне по F1. В самом биосе по умолчанию опция включена. А на 7551 при подключении USB клавиатуры и с родным биосом и с биосом от 7550 клавиатура в устройствах определяется, останавливается загрузка на окне где нужно нажать F1 или F2, но никакие кнопки не работают.

blek1 писал:
А то,что у вас одно ядро ЦП 4"С градуса-это норм?


Поставил этот процессор на 7550. Температура ядер сначала была 14, 38, но уже через минуту упала до 5, 34. Видимо это особенность термодатчика конкретного экземпляра процессора.

Возникло у меня нехорошее предчувствие. Если биос от 7551 залить в 7550 то в мониторинге и в биосе и в ОС отображается только температура и не определяется тип датчика. Если выключить комп, то питание с HDD снимается через 10 сек. после выключения платы. На родном биосе HDD выключается синхронно с платой.

Эти же симптомы и плате 7551 даже с родным биосом. Плата попала ко мне с паянным мультом. Я подкидывал на замену 2 мульта - F71882 и EP1308 c одинаковым результатом. Еще когда срисовывал схему заметил что сигнал KB_SEL у 7550 идет с вывода 59, а у 7551 с вывода 61. Как такое может быть если мульты одинаковые или все-таки разные. Может кто-то знает какой мульт должен стоять на 7551?

Первая картинка это 7550 с родным биосом, вторая с биосом от 7551.

7550 с родным биосом


7550 с биосом от 7551


Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3580
Mikkey
 
Сообщение #5 от 21/12/2015 18:59 цитата  

Мульт F71882
Проверьте полевики Q75..Q78 и Q57..Q60

  MS-7551_r1.0_PS2.gif  83.43 КБ  Скачано: 159 раз(а)
alex_kvb 
Бывалый
Сообщения: 38
 
Сообщение #6 от 21/12/2015 23:39 цитата  

Mikkey писал:
Мульт F71882
Проверьте полевики Q75..Q78 и Q57..Q60


Mikkey, спасибо. Сверил с тем что сам нарисовал - совпало, что радует. Выпаял все полевики, проверил мультиметром - все рабочие, открываются и закрываются. С выпаяными транзисторами напряжение на выв. 70 и 72 при вкл. также падает до 0. Такое впечатление что что-то не отпускает клок после ресета. На всякий случай кинул напрямую KDATA (69) KCLK (70) на разъем PS/2 - ничего не изменилось. Может когда первый раз меняли мульт что-то снесли. Хотелось бы проверить всю обвязку мульта, буду очень благодарен за эту часть схемы.
Michael666 
Завсегдатай
Сообщения: 540
Michael666
 
Сообщение #7 от 22/12/2015 22:45 цитата  

alex_kvb,
Вобщем я столько букв не осилю , но похожее было .
MS-7551 это KA780G и KA780G-M и ещё много всего похожего . Там этикетка на обороте платы и там есть длинный номер , который и определяет и модель и версию биос . Зашейте от KA780G-M , я б от всех MS-7551 попробовал - терять то нечего , а мульт и его обвязка , думается , тут не при чём .
У меня была проблема с MS-7519 к которой не смотря ни на какие надписи кроме длинного серийника на этикетке подошёл биос от P43D3 Neo-F и снялись проблемы в определении проца и загрузки с USB .
Lenchik 
Фанат форума
Сообщения: 7937
Lenchik
 
Сообщение #8 от 22/12/2015 22:53 цитата  

Если можно зайти в настройку BIOS то там надо включить USB Keyboard или что то подобное. Если нет то надо включить USB Legacy. Без этого USB устройства работают только после загрузки драйвера.
alex_kvb 
Бывалый
Сообщения: 38
 
Сообщение #9 от 23/12/2015 02:00 цитата  

Michael666 писал:

MS-7551 это KA780G и KA780G-M и ещё много всего похожего . Там этикетка на обороте платы и там есть длинный номер , который и определяет и модель и версию биос . Зашейте от KA780G-M , я б от всех MS-7551 попробовал - терять то нечего , а мульт и его обвязка , думается , тут не при чём.

К сожалению, этикетки на обратной стороне нет. Проверил все 4 биоса от 7551 - результат тот же. Прошил эти же 4 биоса на 7550 - клавиатура PS/2 определяется на всех прошивках, с USB клавиатуры в биос заходит, в мониторинге только обороты. На одной из прошивок (K790GX-M) словил полосы на мониторе, но клавиатура PS/2 определилась.
Цитата:

У меня была проблема с MS-7519 к которой не смотря ни на какие надписи кроме длинного серийника на этикетке подошёл биос от P43D3 Neo-F и снялись проблемы в определении проца и загрузки с USB .

Посмотрел на эти платы - практически близнецы. Значит биос подходит с большой долей вероятности если платы на одинаковых чипсетах, одинаковое количество слотов и желательно что бы были внешне похожи. Попробую поискать, может и еще что-то похожее всплывет.

Lenchik писал:
Если можно зайти в настройку BIOS то там надо включить USB Keyboard или что то подобное. Если нет то надо включить USB Legacy. Без этого USB устройства работают только после загрузки драйвера.

В том и проблема, что в биос нельзя зайти ни с PS/2 ни USB клавиатуры (в ОС USB клавиатура работает). По умолчанию в биосе эта опция включена (проверено заливкой биоса от 7551 в 7550), да и надпись что биос обнаружил USB клавиатуру тоже говорит об этом.
Буду дальше разбираться, хорошо что схема уже есть, может и с железом что-то, плата с неизвестной историей, поэтому ничего исключать нельзя.
n max 
Модератор
<B>Модератор</B>
Сообщения: 11680
 
Сообщение #10 от 26/12/2015 10:57 цитата  

Надо осцилом сигнальчики посмотреть на разъёме клавиатуры потом гадать будем.Там ещё мышь должна быть ПС\2 она хоть работает?
alex_kvb 
Бывалый
Сообщения: 38
 
Сообщение #11 от 26/12/2015 18:43 цитата  

Линия Clock (70, 72) не поднимается после ресета - 0 V. Я даже отпаивал 70 ножку мульта - все равно 0 после старта. Пока на этих ногах не будет 5 V, ничего работать не будет. Осциллом смотрел прямо на ножках мульта - то же самое, с дежурных 5 V падает до 0, мышку подключал - светится, но не работает, что впрочем ожидаемо. Пока в планах снять напряжения на выводах мульта и сравнить с рабочей платой в дежурном режиме, зажатом ресете и после старта. Еще есть мысли заменить микросхему биоса (сомневаюсь что поможет, но попробовать можно) и запаять один из мультов на рабочую плату.
n max 
Модератор
<B>Модератор</B>
Сообщения: 11680
 
Сообщение #12 от 27/12/2015 10:59 цитата  

Да пока не надо трогать микросхемы.,Для начала сам разъём прозвонить на обрыв\замыкание.

Перейти: 
Следующая тема · Предыдущая тема
Показать/скрыть Ваши права в разделе

Интересное от ESpec


Другие темы раздела Настольные компьютеры



liveinternet.ru RadioTOP Rambler's Top100 Рейтинг@Mail.ru