ESpec - мир электроники для профессионалов


Коллеги, zyxel omni 56k neo ee

  Список форумов » Настольные компьютеры

Следующая тема · Предыдущая тема
АвторСообщение
georgich 
Бывалый
Сообщения: 42
georgich
 
Сообщение #1 от 10/02/2005 14:02 цитата  

Модем не определяется компом. При вскрытии обнаружено что Vcc gd75323 и соответственно всей начинки составляет 3.2в, напряжения -и+12в в норме. Вопрос, а не маловато ли для Vcc. Вторичный БП собран на AP34063, генерация идет, но форма импульсов не нравится, с затуханием. ИМХО что-то коротит
Подскажите, если кто сталкивался с такой ерундой
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #2 от 10/02/2005 14:14 цитата  

Вполне нормально, зачем на проц, питающийся 3,3В подавать сигналы в 5В? улыбка
Проверь прохождение сигналов от и к 75323, там идёт преобразование 0/3,3 в -12/+12. Даташит есть?
Что значит форма не нравится? Пульсации чтоль большие? Преобразователь там на дросселе, потому никаких прямоугольников и в помине быть не может.
georgich 
Бывалый
Сообщения: 42
georgich
 
Сообщение #3 от 10/02/2005 15:53 цитата  

В даташите как раз и написано Vcc=5вольт, а для питания проца собран делитель на 2-х резюках и транзисторе .
Лучше, подскажите, в случае сборки вторичного БП на кренке, там место есть, только девайс не установлен, на какое, всё таки напряжение кренка,
Да и 74-серия(стоит на плате), кажется тоже 5в питается
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #4 от 10/02/2005 17:56 цитата  

Спорить не буду, но если мне память не изменяет, то все новые омники от 3,3 питаются (по крайней мере все что ко мне попадали), и эти 3,3 делает именно 34063, даже 24с02 от 3,3 питается. Точно уверены что там отделбный стабилизатор на проц? Обычной прозвонкой можно вычислить что от чего питается.
Я когда впервый раз с таким питанием столкнулся тоже начал ОС подбирать, чтоб 5В получилось голливудская улыбка , всё греться начало...
Дополнительные места обычно используются в других моделях, скажем для тех у которых реле есть, или USB.
Так сигналы-то нормально проходят RTS, DTR, TxD, RxD или нет?
Ни на один вопрос не отвечаете и хотите помощи недовольство, огорчение Если так и дальше пойдёт то Бог Вам в помощь улыбка
enigm25 
Заглянувший
Сообщения: 9
 
Сообщение #5 от 11/02/2005 00:26 цитата  

georgich, а куда цепляеш com1 или com2 ? и с нуля ставиш или он уже работал?
если на сом2 а на сом1 мыша висит то дергай мышу и вместо нее втыкай модем
99 из 100 заработает если заработает делай выводы
буквально вчера пришол модем ставить .
в сом2 воткнул а комп невидит . дернул мышу и воткнул модем в сом1 пустил и комп увидел модем правда без мыши
пришлось сом2 дергать и вместо 25 ставить 9 и все ок
пробуй а вось поможет
Нет
georgich 
Бывалый
Сообщения: 42
georgich
 
Сообщение #6 от 11/02/2005 10:39 цитата  

Спасибо за информацию, Mikkey, сигналы от компа проходят RTS,DTR (я имею в виду через 75323), а от мдема тишина, кварц на плате работает, вот я и подумал, что напруги маловато, и соответственно, что-то не отрабатывает
Второе: БП визжит громковато
Третье: даташит 75323 указывает на 5в
Вот поэтому и возникла необходимость задать вопрос относительно напряжения питания
Enigm25, у меня не комовская мышь, но всёравно спасибо
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #7 от 11/02/2005 12:10 цитата  

Вобщем написал тут для себя прогу, тестить модемы, потихоньку дорабатываю, глюки пока есть, но обходимые улыбка
http://mikkey.at.tut.by/com.zip - более менее рабочая
http://mikkey.at.tut.by/com1026b.zip - пока на отладке
В последней зделал полное зацикливание посылки в порт, чтоб проверять именно такие неотвечающие модемы, ставишь скорость поменьше, открываешь порт - Start, потом жмёшь Strt - начало постоянной посылки в порт, вместо ATI2 можно написать строку подлиннее (для наглядности наблюдения осцилом). Если в логе Error writing to port! то тискай Reset (первый из глюков, пока с флагами не разобрался улыбка). И второй глюк, не закрывай порт/прогу, пока не остановишь цикл или автоопрос, иначе бывает подвисает улыбка
Трям 
Завсегдатай
Сообщения: 987
 
Сообщение #8 от 11/02/2005 12:15 цитата  

А может просто прошивка слетела ???
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #9 от 11/02/2005 12:25 цитата  

Очень похоже, но эти модемы ничего не отвечают, способа ввести в кернел неизвестно, потому единственная возможность - внешний программатор, но проблемы с переходником и полной прошивкой, те что идут для обновления - урезанные, 7С000-7CFFF не хватает, т.е. самого кернела (аналог бут-блок в БИОСах для мамок).
На http://hardw.net/forum/viewtopic.php?p=26483 проскакивало, что надо ставить перемычку кудато, чтоб можно было прошить.

Добавлено 11.02.2005 11:39

для обычного 56к это давно известно, а вот на новые куда хммм...
Трям 
Завсегдатай
Сообщения: 987
 
Сообщение #10 от 11/02/2005 12:45 цитата  

Ёшкин-кот.. если Ваш модем при включении дважды Мыргнул зелёным глазом и всё - значит он в кернел Моде..скачиваете с сайта Зухеля прошивку и прошивальшиц.. перепрошиваете -и ВСЁ ..
Ну это в двух словах самая суть..
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #11 от 11/02/2005 12:48 цитата  

Трям, чтоб прошивальщик начал шить, он должен получит ответ от модема, что тот в кернеле, а если он молчит?...
Когда модем в кернеле, то на любую команду в терминалке он об этом сообщит, ну кроме ATI1, ATI2 вроде, по ним он свою версию выдаёт.
Трям 
Завсегдатай
Сообщения: 987
 
Сообщение #12 от 11/02/2005 20:48 цитата  

Mikkey, ну а я про что написал ?? А если не в кернеле, то загнать его туда, коротнув при включении 16-17( если ничего не путаю) ноги Флэшки..
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #13 от 12/02/2005 16:16 цитата  

А ты пробовал на новых омниках? Просто интересно, на 56к без проблем, и флэшку коротнуть, или на худой конец полную перешивку (и кернел тоже) сделать, но на новых, все признаки слёта прошивки, но ввести его в кернел не получалось, молчали как рыба об лёд.
georgich 
Бывалый
Сообщения: 42
georgich
 
Сообщение #14 от 15/02/2005 15:21 цитата  

Извиняюсь за долгое молчание, обстоятельства.
Да, правы Вы, действительно прошивка слетела
На ati1, пишет 1051 Kernel:1,06 dec 26 2002
Но, записать микропрограмму не удаётся, при запуске zyfwm.exe, скачаной с сайта производителя, находит порт подключения, стирает флешку и вываливает окно ошибка визард, просит сбросить модем и начать сначала.
Подскажите в чём байда, никогда прошивками не занимался
V01d 
Гость
 
Сообщение #15 от 16/02/2005 08:25 цитата  

Для OMNI NEO существует специальная програмеса прошивалка
и прошивка в одном флаконе.
Трям 
Завсегдатай
Сообщения: 987
 
Сообщение #16 от 16/02/2005 10:16 цитата  

Mikkey, Вчера только ОМНИ-МИНИ шил.. без проблем, причём старой СОМ-овской утилитой..
Mikkey 
Старший модератор
<B>Старший модератор</B>
Сообщения: 3583
Mikkey
 
Сообщение #17 от 16/02/2005 12:18 цитата  

Проблем то нет, когда они отвечают нормально.
Я немного не так выразился, скажем когда в 56к слетает прошивка совсем, что корочением адресных ножек флэшки его не ввести в кернел, есть джампер, если его коротнуть то модем входит в режим ROM Code и можно восстанавливать прошивку, а вот в новых как такое сделать неизвестно. недовольство, огорчение
Трям 
Завсегдатай
Сообщения: 987
 
Сообщение #18 от 16/02/2005 12:35 цитата  

Mikkey, ааа.. я просто ещё не сталкивался на новых с этим подшучивать, дразнить

Перейти: 
Следующая тема · Предыдущая тема
Показать/скрыть Ваши права в разделе

Интересное от ESpec


Другие темы раздела Настольные компьютеры



liveinternet.ru RadioTOP Rambler's Top100 Рейтинг@Mail.ru