ESpec - мир электроники для профессионалов


Indesit wt100 принимает программу, но не ничего делает.

  Список форумов » Стиральные и посудомоечные машины
На страницу 1, 2  След.
Следующая тема · Предыдущая тема
АвторСообщение
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #1 от 03/02/2015 20:55 цитата  

Стиральная машина Indesit WT100/1 (CSI) С модулем управления EVO-I LB2000 UNI-ST.
Дело началось с того что у нее замерз сливной шланг и она перелилась.
Сгорел симистор Q4(на его место был вставлен Q6, а потом на место Q6 чуть позже был приобретен и впаян новый симистор) Двигатель был в "залипшем" состоянии (судя по всему щетки прилипли к якорю), после того как провернул вал плоскогубцами, стал вращаться нормально. Двигатель снял,просушил, подключил к лабораторному блоку питания - крутится нормально. Симистор Q1(двигателя)- рабочий. Тахогенератор тоже работает (проверил осциллографом). Проверил прессостат, на первый уровень срабатывает нормально,а вот на перелив сработал только когда отсоединил от него трубку, и подул в него... Клапана рабочие (проверял закорачиванием симистора)
Контроллер общается с еепромом (тоже смотрел осциллографом на 3,4 выводах 93c86) прошивка рабочая (так сказали в соседней ветке).

В данный момент машинка принимает программу, и молча стоит ничего не делая (не набирает воду, не сливает если включить соответсвующую программу) Если отключить от модуля прессостат или датчик температуры СМ сообщает об ошибке (вращается КА, работает помпа, светодиод моргает код ошибки, и по моему заливается вода)

Со мной поделились прогой lb_sat (чтобы провести компьютерную диагностику), но ком порта у меня нету, поэтому хотел её подключить через FT232RL к модулю, но программа ничего не шлет(не моргают светодиоды припаянные к FT232, хотя ком порт она вроде как видит, если указан не существующий порт не запускается мониторинг).

Может кто нибудь знает описание протокола чтобы мне пообщаться с машинкой без проги, или может посоветуете еще какие нибудь диагностические приемы чтобы выяснить почему она себя так ведет?
Мастерюга 
Передовик
Сообщения: 2031
 
Сообщение #2 от 03/02/2015 21:07 цитата  

elvoblin писал:
....Может кто нибудь знает описание протокола чтобы мне пообщаться с машинкой без проги...

Обними, поцелуй, пошепчи нежных слов ей.... гы-гы
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #3 от 03/02/2015 21:15 цитата  

Мастерюга писал:

Обними, поцелуй, пошепчи нежных слов ей.... гы-гы

Ну не совсем же без проги, можно например с помощью putty, ну или с помощью скрипта на питоне или еще чем нибудь - не важно. Главное понять что ей отправлять на ногу Rx и понимать что она отвечает на ноге Tx...
Мастерюга 
Передовик
Сообщения: 2031
 
Сообщение #4 от 03/02/2015 23:00 цитата  

elvoblin, Мастера вызови, придёт и сделает.... без проги, без скриптов... нежных слов от него тоже вряд ли услышишь, но машинка будет работать смех
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #5 от 03/02/2015 23:17 цитата  

Не за что мне вызывать мастера, и новую машинку тоже не за что купить за последние 7 месяцев я получил 2800 грн. и это было в середине осени, у нас тут немножечко война...
Александр Михалыч 
Фанат форума
Сообщения: 4708
Александр Михалыч
 
Сообщение #6 от 03/02/2015 23:27 цитата  

elvoblin,
1, -От неисправного сима цепочка (к процу) пострадала?
2, -Когда машинка "принимает прогу", - замок блокирует? светик замка отрабатывает?
Мелиор 
Старший модератор
<B>Старший модератор</B>
Сообщения: 30266
Мелиор
 
Сообщение #7 от 03/02/2015 23:43 цитата  

Мне нравится эта формулировка "помогите найти проблему" ! Проблемы решать надо, а не искать смех
А если серьезно - исправляй заголовок, указывай суть вопроса
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #8 от 04/02/2015 08:06 цитата  

Александр Михалыч писал:

1, -От неисправного сима цепочка (к процу) пострадала?
2, -Когда машинка "принимает прогу", - замок блокирует? светик замка отрабатывает?


1. Вроде нет, детальки целые. нога проца не пробита. ,смотрел туда осциллографом там +5В, состояние после приема программы не изменяется.
2. Люк блокируется, Светодиод замка - загорается, светодиод питания несколько раз быстро моргает и тоже загорается. Все как и должно быть (ну насколько я помню)
anisvalerij 
Участник
Сообщения: 112
anisvalerij
 
Сообщение #9 от 04/02/2015 08:42 цитата  

интересно,а компьютерных сетях вся периферия тоже проверяется закорачиванием?включи машинку и дождись пока покажет ошибку
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #10 от 04/02/2015 08:59 цитата  

anisvalerij писал:
включи машинку и дождись пока покажет ошибку

Я ждал минут 20 она её так и не показала.

Насчет переферии я не совсем понял... Вот есть клапан который нужно проверить, он работает от 220В я его подключаю к 220В он включается - чем плох этот способ? Ну естественно я предварительно проверил что у обмотки нормальное сопротивление.
anisvalerij 
Участник
Сообщения: 112
anisvalerij
 
Сообщение #11 от 04/02/2015 09:07 цитата  

проверить нужно,но не закорачиванием симистора,прозвони двигатель на разьеме модуля
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #12 от 04/02/2015 09:15 цитата  

anisvalerij писал:
проверить нужно,но не закорачиванием симистора,прозвони двигатель на разьеме модуля

Симистор я закорачивал на клапане.

Цитата:
Двигатель снял,просушил, подключил к лабораторному блоку питания - крутится нормально.

Могу скинуть ссылку на видео.

На разъеме модуля я его тоже прозванивал (если вы ведете к тому что повреждены разъемы или провода - они в порядке)
anisvalerij 
Участник
Сообщения: 112
anisvalerij
 
Сообщение #13 от 04/02/2015 09:37 цитата  

я веду к тому,что видит ли процессор двигатель,прозванивай остальную периферию на разьемах модуля(УБЛ,ТЭН,помпа и т.д)
Мастерюга 
Передовик
Сообщения: 2031
 
Сообщение #14 от 04/02/2015 09:48 цитата  

elvoblin, поменяй ТЭН на...




elvoblin 
Новичок
Сообщения: 15
 
Сообщение #15 от 04/02/2015 22:10 цитата  

Лампочку вместо тена подключал, только не такую, а галогенную 50W 220W на поведении машинки это никак не отразилось.

переферию прозвонил еще раз, все на месте кроме УБЛ, как я понял через него через CNF/6 на модуль приходит 220В К которым подключена периферия, после блокировки люка, и они таки туда приходя. Больше ничего связанного с УБЛ я не обнаружил
Александр Михалыч 
Фанат форума
Сообщения: 4708
Александр Михалыч
 
Сообщение #16 от 04/02/2015 22:17 цитата  

Александр Михалыч писал:
elvoblin,
......., - замок блокирует? светик замка отрабатывает?

elvoblin писал:
....... Люк блокируется, Светодиод замка - загорается, ......

elvoblin писал:
......, все на месте кроме УБЛ, ...


elvoblin, Поясни, - это как?
Dima700926 
Модератор
<B>Модератор</B>
Сообщения: 5021
Dima700926
 
Сообщение #17 от 04/02/2015 22:25 цитата  

elvoblin, если ты такой продвинутый, почему бы тебе просто не слить прошивку с 93с46 (или 86, не помню, какая там) и не выложить?
Александр Михалыч 
Фанат форума
Сообщения: 4708
Александр Михалыч
 
Сообщение #18 от 04/02/2015 22:28 цитата  

Dima700926, Он выкладывал. "в прошивках" (стр 277)
elvoblin 
Новичок
Сообщения: 15
 
Сообщение #19 от 04/02/2015 22:36 цитата  

А вот теперь уже и не знаю как) я имел виду что не увидел на схеме какого-то специального разъема для контроля УБЛ, но действительно МК как то же узнает что люк заблокирован... Может через 1й Вывод МК?
yura14 
Передовик
Сообщения: 2713
yura14
 
Сообщение #20 от 04/02/2015 22:37 цитата  

elvoblin писал:
... Двигатель был в "залипшем" состоянии ... может посоветуете еще какие нибудь диагностические приемы чтобы выяснить почему она себя так ведет?
А ты применял приём по контролю за состоянием щёток ??? Чего это они "прилипли" к якорю ??? Диффузия, что ли ? смех

Перейти: 
Следующая тема · Предыдущая тема
На страницу 1, 2  След.
Показать/скрыть Ваши права в разделе

Интересное от ESpec


Другие темы раздела Стиральные и посудомоечные машины



liveinternet.ru RadioTOP Rambler's Top100 Рейтинг@Mail.ru