ESpec - мир электроники для профессионалов


Стиралка Electrolux ews 1020 глюки, выключается

  Список форумов » Стиральные и посудомоечные машины
На страницу 1, 2  След.
Следующая тема · Предыдущая тема
АвторСообщение
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #1 от 14/11/2006 11:24 цитата  

Коллеги, добрый день.
Купил стиралку Electrolux EWS 1020 (будь она неладна). Через месяц после окончания гарантии начала глючить, выключаться. Выглюдит это так: запускаешь программу стирки, начинает стирать, в любой момент (независимо от времени) останавливается, начинает мигать всеми светодиодами сразу в хаотическом порядке. Выключаешь сеть, включаешь - мигают. Если в
момент вспышки светодиодов нажать кнопку включения программы, то может включиться, но ненадолго.
Залез в блок питания, на всякий случай поменял все электролитические конденсаторы (их там всего четыре: три по
вторичным цепям питания, один - в сети 47 мкф 450 вольт). Во вторичных цепях поставил конденсаторы большей ёмкости, на всякий случай. Проверка осциилографом цепей питания (+5 вольт и +11 вольт) показала, что в момент появления глюков в питании видны некоторые высокочастотные помехи. Подключал на +5 вольт и на +11 вольт конденсаторы на 0,1 мкф для устранения этих помех - никакого результа.
В машинке две платы: основная (с блоком питания и процессорами) и плата клавиатуры и индикации (с контролллером). Между платами идет обмен по трёх-проводной шине. Когда машинка работает нормально - обмен по шине выглядит нормально, но в момент глюков на этих шинах тоже начинается какая-то помеха. Интуитивно чувствую, что дело с питанием, но что понять не могу.
Опыта работы со стиралками - нет. Всю жизнь ремонтирую телевизоры, видео, аудио технику. Пробовал подключать лабораторный блок питания параллельно шинам питания (для подпитки на случай возможных просадок питающих напряжений), сначала на +5 вольт, затем на +11 вольт - положительного результата нет (глючит). Заменил микросхему блока питания TNY 253 G. Не помогло.
Обращался за помощью к знакомым ребятам в сервисный центр данной торговой сети - отвечают, мол Электролюксы не делаем,
отвозим в платную мастерскую, там делают. Я узнавал, за работу берут тысячу рублей. Плюс заморачиваться не хотят, сразу
меняют блоки основной и индикации-управления. А это еще 2.5 - 3 тысячи рублей (ну и цены !!!). Вот и пытаюсь пока сам догадаться, что с ней случилось. Неужели с опытом работы с электронной техникой 22 года не догадаюсь, что случилось. Схемы нет, найти не смог даже за деньги. Пытался с основной платы срисовать схему, но это задача тяжелая, в добавок двухстронняя печать на плате. Срисовал только блок питания.
Меня еще такой вопрос интересует, есть ли у схемы гальваническая развязка от сети, у меня подозрение, что нет, сетевая вилка звонится на общий провод платы всего 2 килоома. Таким образом, осциллографом в нем лазить без переходного трасформатора опасно, можно сжечь осциллограф, а заодно и машинку дожечь до конца.
В интернете про эти машинки столько матерков. В основном жалуются на процессора. Купил машинку за 18 тысяч полтора года назад
(чё я Самсунг не купил, тот хоть стоит в два раза дешевле). Неужели теперь еще 3 - 4 тысячи платить за ремонт. Может, мелочь какая, транзистор или еще чего. Напряжение сети проверял - 220 - 225 вольт.
Еще вопросы: какие функции выполняют реле (их там три) и тиристор?
Братцы, прошу дать серьезный совет, как сделать эту гадину, желательно без замены блоков.
Сергей. Барнаул.




moon 
Завсегдатай
Сообщения: 675
 
Сообщение #2 от 14/11/2006 12:53 цитата  

Присяжный Сергей, светодиоды моргают все сразу или какие то не горят, а какие то мигают ?замерьте напряжение в розетке не отключая машинки из сети, в момент когда она мигать начинает !если ниже 200вольт , то дело в напряжении в сети !если мигают все лампочки ,то....дешифратор который стоит на плате индикации у вас скорее всего отшёл в мир иной !опишите подробно какие лампочки мигают, там видно будет , что сней делать !
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #3 от 14/11/2006 14:58 цитата  

Светодиоды моргают те, которые горели до остановки. Если изменить режим стирки, то светодиоды, естественно, начинают моргать другие, соответствующие данному режиму стирки.
С напряжением сети всё нормально (220-225 вольт)
У меня постоянно подключен вольтметр на вводе сети в квартиру.
мишання 
Бывалый
Сообщения: 59
мишання
 
Сообщение #4 от 14/11/2006 15:55 цитата  

Цитата:
У меня постоянно подключен вольтметр на вводе сети в квартиру.

Вот надо смотреть напряжение на самой стиралке,во время остановки.На входе всегда будет нормальное,если соединения зажаты.
Rain 
Передовик
Сообщения: 2781
Rain
 
Сообщение #5 от 14/11/2006 16:29 цитата  

мишання прав, 100%.
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #6 от 14/11/2006 16:53 цитата  

Померил напряжения сети на плате - 228 вольт. Мигают одновременно несколько светодиодов, которые до остановки машинки горели. При смене режима стирки начинают мигать другие светодиоды, соответствующие режиму стирки.
Мигание хаотическое (безсистемное), как будто питание подается на секунду и тут же пропадает.
На плате три реле и тиристор. Какая у них роль?
Rain 
Передовик
Сообщения: 2781
Rain
 
Сообщение #7 от 14/11/2006 17:37 цитата  

Кнопка вкл, есть? Или включается селектором?
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #8 от 14/11/2006 18:36 цитата  

Есть селектор переключения режимов стирки. Есть кнопка включения, есть кнопка включения сети.
Из блока питания в схему уходят два питания: +5 и +11 вольт. Это норма или нет7
В тот момент, когда машина встает и начинают хаотически мигать светоды, обмен по шине между платами начинает выглядеть несколько иначе. В обмене появляется какая-то помеха. Между прочим, похожая помеха наблюдается в питании +5 и +11 вольт.
Что это значит?
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #9 от 14/11/2006 20:21 цитата  

Характер миганий светодиодов не поддается никакой логике (пробовал считать). Несколько светодиодов (количество зависит от данного режима работы) мигают одновременно с непредсказуемыми паузами. Как будто внезапно подали питание на пол-секунды - секунду и тут же сняли.
Я практически полностью исключаю, что мигание светодиодов хоть как-то связано с системой тестирования и самодиагностики.
Может, схема или хотя бы часть ее есть?
Помогите, ребята.
Пол-года машинка парит мне мозги (стиралка-то моя!!!). Перед женой неудобно даже.
Специалисты по стиралкам, отзовитесь.
Rain 
Передовик
Сообщения: 2781
Rain
 
Сообщение #10 от 15/11/2006 11:47 цитата  

Селектор программ ставишь на одно положение вперёд, нажимаешь на пуск и рядом стоящую кнопку и на вкл, далее описываешь что происходит.
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #11 от 15/11/2006 18:59 цитата  

Заметил одну закономерность: если в момент загорания светодиодов нажать кнопку "пуск", то машинка начинает стирать (правда, может остановиться в любой момент), но если включен какой-нибудь режим от "A" до "D" (A - полоскание, B - слив воды, C - отжим, D - бережный отжим), то в машинку включить практически невозможно. Эти режимы она не любит.

Rain, отправляю фото панели управления. Повернул селектор программ на один щелчок по часовой стрелке, нажал кнопку "пуск" и на соседнюю кнопку ("дополнительное полоскание"), включил сеть. Стоит, мигает, нечего не делает.

Заменил на всякий случай электролитический конденсатор на плате управления-индикации (он там всего один). Никаких изменений.
Пошел мыть платы спиртом.

Потом отпишу результат.




Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #12 от 15/11/2006 20:33 цитата  

Rain, Пробовал войти в тест, как ты советовал (1 щелчок селектором по часовой стрелке, нажимаешь "пуск" и "дополнительное полоскание" одновременно (они находятся рядом), включаешь сеть). У меня ничего не получилось. Нет реакции. Как мигали, так и мигают.
Промыл платы спиртом. Проверил монтаж на предмет коррозии или непропаев. Ничего подозрительного.
У процессора (EWM 1000 PLUS W1A30106) на последнем выводе сидит такая 4-х-ногая штуковина 32С49, с позиционным обозничением на плате Y1. Не знаю, что это за штуковина. Мне сказали, что у процессора на 1 выводе должен быть RESET. Проверил. На этом выводе напряжение +5 вольт. В момент загорания светодиодов там происходит сброс напряжения в "ноль" на доли секунды, потом опять 5 вольт. Что это значит. Процессор пытается перезапуститься, что ли?
Дайте еще советы, что посмотреть.
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #13 от 15/11/2006 21:34 цитата  

Мне не нравится одна вещь: по питаниям +5 и +11 вольт видна осциллографом ВЧ помеха. Возможно, что она заставлает процессор перезапускаться. В процессе многих попыток ремонта я заметил, что глюки начинаются тогда, когда появляется эта помеха. Возможно, лезет ВЧ с блока питания. Все электролитические конденсаторы поменял на новые, даже с большей емкостью поставил, но от ВЧ в питании избавиться не могу. В связи с этим у меня вопрос: а что если собрать БП на обычном трансформаторе с диодными мостами, конденсаторами, стабилизаторами. Будет работать или нет?
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #14 от 16/11/2006 08:07 цитата  

Вот схема БП.
Померил очень внимательно напряжения от средней точки трансформатора БП. У меня получилось +6,11 и -5,18. Цифровой вольтметр Отключил разъем J8 - напряжения изменились на +6,17 и -5,27.
Проводил эксперемент: подключил параллельно лабораторный блок питания на цепь +7 вольт. Мигания прекратились. На кнопки не реагирует, переключения селектора ничего не изменило. Пробовал войти в сервис - не получается. Отключил блок питания от 7 вольт - опять замигали. И при подключенном дополнительном БП и при отключенном по шинам на разъеме J8 идет обмен, на 1-ом выводе процессора (RESET) 5 вольт с импульсами в "0" с одинаковой периодичностью 1.5 - 2 секунды. Это нормально?




Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #15 от 16/11/2006 14:36 цитата  

Сегодня купил память на нее. Сейчас попробую заменить, потом кварц (32768).
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #16 от 16/11/2006 21:14 цитата  

Для пробы заменил память. Включаю. Мигает вся правая линейка светодиодов вместе с тактом около 1 сек. Понял так: либо память дохлая попала, либо процессору не нравиться то, что память пустая. Может ее шить надо. Старая память - без метки краской, которую ставят обычно на заводе, если память ставится прошитая.

Сделал следующее: поменял память на старую - включилась, стоит, ждет пуск. Трогаю память - горячая (только что паял). Через 2 минуты память остыла - опять хаотическое мигание, на 1 выв. проца импульсы сброса.
Сделал вывод - со старой памятью что-то не то. Заменил память на другую новую (из другой партии). Включил. Опять мигает вся правая линейка светодиодов.
Выключил. Нажал две кнопки сразу: пуск-пауза и соседнюю (доп. полоскание). Включил сеть. Ждал 5 секунд. Правая линейка светодиодов мигать перестала, начали перемигиваться светодиоды поочереди: сначала левая линейка сверху вниз, потом середина слева - направо, снизу - вверх, слева - направо, правая линейка сверху - вниз.
Похоже, тест.

Импульсы сброса на 1 выв. проца пропали. Стоит "еденица".
Светодиоды перемигиваются поочереди уже несколько минут. Машинка сама себя развлекает (шутка)
Больной стал стабилен. Для врачей такое наблюдение уже радость. Ему хотя бы не хуже.
Похоже, нужен файл дампа памяти.

Дайте файл для прошивки памяти, если есть для Electrolux EWS 1020. PNC 914756503/00

Интуиция подсказывает, что я очень близок к причине.
Сегодня ездил в магазин за деталями для телека клиента. Думай, дай память новую возьму. 24с64. В телеках такого объема память еще не попадала не разу. Благо, марку памяти заранее посмотрел. Похоже, результат будет. Теперь четко понял - старая память работает, пока горячая, после пайки ее или соседних элементов.

Всё так же стоит и перемигивается. Не выключается.

Короче, я сразу не стал писать. Я платы из машинки вынул, нашел, где подать сеть, подключил у себя на столе через развязывающий трансформатор, да еще через лампочку на 15 ватт 220 вольт. Так спокойнее. Похоже, кое-что на этих платах можно посмотреть и не подключая переферии машинки. И осциллографом лазить можно спокойно. И за фазу руками случайно не схватишься.
Слушайте, а что ж они гальваническую развязку от сети в машинках не делают? Так же больше шансов, что где-то фаза и вода навредят. Много видел в интернете нареканий от людей на качество процессоров в Электролюксах. Так может наличие фазы виновато. В телевизорах многих моделей тоже встречаются БП без гальванической развязки от сети. Так там такие чудеса бывают!!! Как то, взрыв в блоке питания. Или просто контроллеры или видеопроцессора дохнут ни с того ни с сего. А если еще хозяин - балбес и пытается к такому телеку чего-нибудь нестандартно подключить (есть такие умники), так и подключенную технику жгуг. Даже, бывает, соседям достается. По антенне. Она ведь заземлена экраном в тех же самых электрощитах в подъездах.

Завтра попробую слить дамп со старой памяти, да залить в новую. А вдруг получится.

Результат отпишу.
moon 
Завсегдатай
Сообщения: 675
 
Сообщение #17 от 17/11/2006 00:36 цитата  

Присяжный Сергей писал:
Завтра попробую слить дамп со старой памяти, да залить в новую. А вдруг получится.

классно! одобряю.ещё можно дамп кинуть на всеобщее обозрение, на просмотр наличия ошибок и сравнения с рабочим дампом.
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #18 от 17/11/2006 06:58 цитата  

так и сделаю
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #19 от 18/11/2006 20:40 цитата  

Привет всем!
Давно ничего не писал, т.к. получилась заморочка с новым программатором. Но решил.

Короче, отчет о проделанной работе.
Сразу скажу - машинка не работает.
Зашил файлом, который мне прислал Alexzz. Вставил в машинку. Включил. Опять всё то же хаотическое мигание. Пробовал войти в тест - не входит.
Слил со старой памяти, изъятой из моей машинки, дамп. Зашил в микросхему. Вставил. Включил. Хаотическое мигание. Пробовал войти в тест - не входит.
Сравнил с помощью программы "Total Commander 6.03" файлы от Alexzz и файл со старой памяти машинки - обнаружил много разницы. Могу переслать оба файла прошивки (с пояснительным текстом) на этот сайт. Для сравнения. Для использования. Вдруг кому надо. Скажите, как отправить.
В общем... Буду искать дальше и надеяться на чудо или чью-то помощь.
Присяжный Сергей 
Новичок
Сообщения: 27
 
Сообщение #20 от 19/11/2006 21:39 цитата  

Сегодня провел эксперемент - Накапал на процессор ацетоном с целью резко остудить. Включил - мигает, на 1-ом выводе процессора импулься сброса. Капаю ацетоном на процессор включенной машинки, он при этом резко остывает, импульсы сброса на 1-ом выводе пропадают, мигать перестала - включилась. Стоит, ждет нажатия кнопки старт-пауза. Постояла немного, опять хаотически замигала. Опять капаю ацетон на процессор, опять через несколько секунд включается на некоторое время.
Похоже, вывод печальный - ПРОЦЕССОР СДОХ.

Надо искать процессор (пусть даже б.у.) или плату.

Перейти: 
Следующая тема · Предыдущая тема
На страницу 1, 2  След.
Показать/скрыть Ваши права в разделе

Интересное от ESpec


Другие темы раздела Стиральные и посудомоечные машины



liveinternet.ru RadioTOP Rambler's Top100 Рейтинг@Mail.ru